Cisco IOS Technologies

CISCO Exam Lab EIGRP 2017

Audain.net has a small netwok that is using EIGRP as its IGP.

All routers should be running an EIGRP AS number 12.  Router MGT is also running static routing to the ISP.

Audain.net has recently adding the ENG router.  Currently, the ENG router does not have connectivity to the ISP router.  All other interconnectivity and internet access for the existing locations of the company are working property.

The task is to identify the fault(s) and correct the router configuration(s) to provide full connectivity between the router.

Access to the router CLI can be gained by clicking on the appropriate host.
All passwords on all touters are cisco.
IP addresses are listed in che chart below.

MGT

Fa0/0 – 192.168.77.33
S1/0 – 198.0.18.6
S0/0 – 192.168.27.9
S0/1 – 192.168.50.21

ENG

Fa0/0 – 192.168.77.34
Fa1/0 – 192.168.12.17
Fa0/1 – 192.168.12.1

Parts1
Fa0/0 – 192.168.12.33
Fa0/1 – 192.168.12.49
S0/0 – 192.168.27.10

Parts2
Fa0/0 192.168.12.65
Fa0/1 – 192.168.12.81
A0/1 – 192.168.50.22

Answer We should check the configuration of the new added router first because it does not function properly while others work well. From the command line interface of ENG router, enter the show running-config command:

Password: cisco
ENG>enable
Password: cisco
ENG#show running-config

From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 112. When the AS numbers among routers are mismatched, no adjacency is formed.

ENG#show running-config
!
router eigrp 112
network 192.168.77.0
network 192.168.12.0
!

To solve this problem, we simply re-configure router ENG with the following commands:
ENG(config)#no router eigrp 112
ENG(config)#router eigrp 12
ENG(config-router)#network 192.168.77.0
ENG(config-router)#network 192.168.12.0
ENG(config-router)#no auto-summary
ENG(config-router)#end
ENG#copy running-config startup-config

Now, we should check the configuration of the MGT router, enter the show running-config command:

Password: cisco
MGT>enable
Password: cisco
MGT#show running-config
!
router eigrp 12
network 192.168.27.0
network 192.168.50.0
network 198.0.18.0
!

Notice that the network 192.168.77.0 is missing from the router eigrp 12 network command. To solve this problem, we have to add it so all other routers will add the network in their routing tables:
Password: cisco
MGT>enable
Password: cisco
MGT#configure terminal
MGT(config)#router eigrp 12
MGT(config-router)#network 192.168.77.0
MGT(config-router)#end
MGT#copy running-config startup-config

Now the whole network will work well. You should check again with ping command from router MGT to other routers.

Note: You should check the AS numbers and configuration on all other routers.

Modifications:
If the link between (MGT to Parts1; or MGT to ENG; or MGT to Parts2) routers has the “passive interface” then we have to remove it with the “no passive-interface …” command because it prevents EIGRP update from being sent on that interface. But if the “passive interface” is applied to the link between R1 and ISP router like this: On MGT router:
MGT# show run
!
router eigrp 12
passive-interface s1/0
!

then we just leave it. Don’t use the “no passive-interface s1/0” on MGT router because the link between MGT router & ISP doesn’t need EIGRP to run on it.

A static route from MGT router to ISP & “ip default-network” command in MGT router are correct so that all the routers (MGT, Parts1,ENG,Parts2) can access the Internet.

(Note: The “ip default-network” command in MGT router will advertise the static route of MGT router (to go to the Internet) to other routers (Parts1,ENG,Parts2) so that they can access the Internet too). In the exam you will see these lines in MGT router configuration:
MGT# show run
! ip default-network 198.0.18.0
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!